Change WordPress user roles and capabilities Forums Bug Reports Role capabilities won’t save

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7326
    learric
    Participant

    I updated to version 4.59.1 and now when I check a box next to a capability and save it, the checkbox is unchecked and the change is not saved. This has happened on more than one site and the issue persists even after disabling all other plugins and changing themes. Version 4.58.2 works fine on all sites affected.

    #7327
    Vladimir
    Keymaster

    Can I look at one of the sites where URE does not save capabilities with administrator permissions, possibly development copy without critical data? If Yes, send URL and login credentials to support [at-sign] role-editor.com

    #7331
    Vladimir
    Keymaster

    You found a bug. Thanks for your help.

    URE does not save changes in case its option “Confirm role update” is switched Off.
    Work temporally with confirmation of any update. I will add the fix with a next update.

    #7333
    learric
    Participant

    Glad I could help, I really like this plugin. Thank you for the temporary solution, I’ll keep an eye out for the update.

    Thanks for the quick response!

    #7968
    Andreas
    Participant

    I unfortunatley run into the same problem. When I set a permisson to a role the plug-in asks me “Please confirm permissions update” I say yes and in the top right corner I get the message “role is updated succesfully”

    When I load the role again, the permission is gone again.

    #7971
    Vladimir
    Keymaster

    Hi Andreas,

    It would be a role from some plugin, which re-creates it dynamically on every page open. Share this role ID. Some roles include a part of plugin name to its IDs.

    Or try temporally deactivate all plugins except URE. Will you can update role after that?
    If Yes, activate plugins back one by one and make new test to isolate a plugin to which this role belongs.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.