Change WordPress user roles and capabilities Forums How to or FAQ Block widgets on multisite but they still are visible :(


Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #3610

    Hi Vladimir,

    I followed the instructions on this page:

    I’m on a multisite.
    – Went into my Main site, selected User Role Editor plugin.
    – Selected Administrator.
    – Selected “Apply to All Sites”
    – Selected widgets button and then selected a couple of widgets to block.

    Everything looks good.

    I went into the other site and logged in as administrator, went to the appearance > widgets page.
    Nothing changed. I still see all the widgets, even though they are supposed to be blocked. 🙁

    I went back to main site and checked the plugin, checked the Widget screen and everything looks good. Have several widgets that are selected to be blocked. Cleared my cache. But nothing helps.

    Any idea how to make this feature work on my site?

    Also tried blocking meta boxes but same result, they are visible instead of being blocked.



    I found this forum post and it helped me:

    I went to my network admin > users > user role editor.
    From there I clicked Update Network. It worked!

    Just so I understand better.
    If I want to make changes to roles, widgets, meta boxes, etc. I should do this from the Network Admin page and use the Update Network button?

    I’m confused about the Apply to All Sites button. What does that do and when should I use that?



    Thanks for letting me know that an issue was resolved.

    Yes, when you wish to replicate all roles, admin menu, widgets, meta boxes permissions from the main site to the all other subsites of the network you should use “Network Admin->Users->User Role Editor->Update Network” button.

    When you wish to replicate from the main site to other network just one selected role you can turn On the “Apply to All Sites” checkbox at the main site “Users->User Role Editor” before click “Update” button there.

    This feature is inherited from a free version. I didn’t hide it for Pro one.


    Thank you

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.