add_filter( ‘ure_content_view_access_data_for_role’, ‘my_content_view_access_data_for_role’, 10, 2 );

function my_content_view_access_data_for_role( $restriction, $role_id ) {
if ( $role_id==’soc2′ ) {
$restriction[‘access_model’] = 2;
$restriction[‘access_error_action’] = 1;
$restriction[‘data’][‘posts’] = array(49, 101, 100, 99);
return $restriction;

I’ve delete the rest of my php for a try, then desactivate all my plugins.
I’ve put the same setting in the post 99:
– View Access: Prohibit view;
– For Users: All visitors (logged in or not);
– Action: Return HTTP 404 error.
The 49, 101, and 100 use this settings:
View access: “Allow View”
For user: Any User Role
Action : Return HTTP 404 Error

it works for 49, 101, 100 but the 99 is still prohibited.
I really don’t understand my instal is pretty new.
I’ve create another user and a new role with “Read” capability, but this is the same. I do not have cache plugin, and I can see any change I do in live.

Last hope could be a setting into URE settings that I miss or that I should uncheck?
I’ve also tried with “post_type Page” and it is the same than with a Custom Post Type..