Change WordPress user roles and capabilities Forums Bug Reports JQuery/AJAX conflict with Visual Composer

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #3946

    Visual composer 5.2
    Wordpress 4.8
    User Role Editor Pro 4.35.1

    It seems that when I try to use a “post grid” in visual composer, there is a jquery conflict with User Role Editor Pro that stops all post content from loading. This is true in the front-end and in the back-end. When I try to edit a “post grid” in my visual composer settings, clicking the edit button will make the post grid settings appear, but the pop-up will not load.

    This is not the case in User Role Editor (free), which when activated, Visual composer works fine. So it has to be the addition of the pro features that is causing this error to occur. I’m testing this with the “Administrator” role, so I have all capabilities turned on, with nothing being blocked.

    Both the front and back give the following error:
    Failed to load resource: the server responded with a status of 500 (Internal Server Error) /wp-admin/admin-ajax.php


    Can you look at server system log for the more detailed error message related to this 500 error code?

    I tried to repeat an issue with VC v. 5.0 I have on hands, but did not get any errors opening ‘posts grid’ element for editing.
    Can you provide me a copy of VC v. 5.2 (via dropbox or similar)? Use support [at-sign] email address.



    Thank you for the quick response. Unfortunately, I checked my server error log, apache log, and error_log.php. None of them had any additional error messages for this.

    I had also tried this with an earlier version of VC 5.1.1, which is why I decided to upgrade to see if that solved the problem, which it did not.
    I read the changelog of VC 5.1.1 and this was at the top of the file:
    04.04.2017 – ver 5.1.1
    Added: extra security check for grid ajax calls to harden security

    09.03.2017 – ver 5.1
    Added: Element Id for all elements
    Added: Image size control for Grid Builder media elements
    Update: Grid Builder Backend editor style user interface

    I sent you an email with a link to VC 5.1.1, so you can test this version.
    Thank you again!


    I got VC 5.1.1 copy and tested with it. I still can not reproduce an issue. This video shows that I don’t have any JavaScript error at a browser JS console.

    Do you see differences? What I should do to reproduce an issue? Any additional setings for Post Grid element?


    Thank you for making the video, that was very kind of you!
    Well, I turned on the last option in the User Role Editor options called “activate content view restrictions,” default view = Allow View, For users = any role, show access error message.

    I am using Buddypress, custom post types, and the custom post type UI plugins.
    I played around disabling some of them, and choose to disable the custom post type UI.

    These settings made my post grid work again!
    This is not what I would have assumed though. When an option says “turn on restrictions,” my thoughts would be to NOT choose that if something is broken.

    I hope this information is helpful 🙂
    Thank you!


    OK. We made a step forward: 3 plugins are involved somehow.

    You can saw at demo video – I activated all available add-ons at URE Settings.
    I activated Custom Post Type UI plugin and re-tested an issue with my own test settings and data of course. There is no JavaScript or AJAX error when I open ‘Post Grid’ element for editing.

    Can you repeat an issue at the site copy with a test database, which you can share? I mean I can download than the files and database data and easy reproduce a problem at my development environment in order to analyse it and offer a solution.


    Thank you for all your hard work with looking into this. Unfortunately I don’t have a test environment that I can give you access to at the moment. I can list all the active plugins that I am using on my platform.

    Admin Custom Login – Version 2.5.2
    Advanced Custom Fields PRO – Version 5.5.14
    Advanced Custom Fields: Nav Menu Field – Version 2.0.0
    BP Registration Options – Version 4.3.2
    BuddyPress – Version 2.8.2
    CB Change Mail Sender – Version 1.1
    Conditional Profile Fields for BuddyPress – Version 1.1.9
    Featured Image From URL – Version 1.5.2
    Force Login – Version 5.0
    Gravity Forms – Version 2.2.3
    Gravity Forms + Custom Post Types – Version 3.1.7
    Really Simple SSL – Version 2.5.17
    Search & Filter Pro – Version 2.3.4
    SSL Insecure Content Fixer – Version 2.4.0
    User Menus – Version 1.1.2
    User Role Editor Pro – Version 4.35.1
    WPBakery Visual Composer – Version 5.2

    I also deactivated the following to fix my issue:
    Custom Post Type UI – Version 1.5.4
    Duplicate Post – Version 3.2


    Thank you for a patience and desire to help in resolving this issue.

    I added “Duplicate Post” to the list of active plugins, but still did not get a described error.

    We can proceed according to one of these variants:
    1) you send me admin credentials for your site, I install backup plugin, create and download a copy of your site to install and work with it at my local development environment. It will be difficult to realize, if your data is too large (>100 Mb).

    2) you create a copy of all files except wp-content/uploads folder and copy of database without wp_users, wp_usermeta, wp_posts, wp_postmeta tables and share them with me via DropBox or similar service. This way you will not open access to any critical or “copyrighted” information if you have any.

    Of course I guarantee you a non disclosure of any information and use your files and data for the investigation purpose only.


    Thank you for offering these suggestions, but I think I can take it from here.
    It seems that no matter WHAT plugin combination I tried, I only had a limit of 18 plugins able to be activated at once, including user role editor pro, before my VC grid builder stopped working.

    This leads me to believe that there is simply excess data or junk in my build that is causing the wordpress “heartbeat” function to overload with ajax calls. I installed the “WP Sweep” plugin to clean out some of the orphaned data and this seemed to help. I have now activated 2 additional plugins and it still seems to work.

    This could also be the case that I don’t have enough memory allocated for my WordPress build?
    I’m not too sure, but it sounds like the cuplrit is more technical, and not related to your plugin at the moment.

    Thank you again for all your help and suggestions!


    OK. Good that you can find a solution for this problem. Yes, ‘not enough memory’ could be a problem.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.