Thanks for your help. I repeated this issue. It will be fixed with a next update – this month.

The reason of a problem is that form edit URL has additional URL parameter ‘id’, which is not allowed as selected menu item URL does not contain it. I will extend the list of allowed URL parameters for Gravity Forms.

Quick workaround – change your “Admin menu” options from “Block not selected” to “Block selected” and then re-check menu items accordingly. You may swap them with ‘Shift’+Click on the top row checkbox.

Gravity Forms dashboard widget shows just forms which have unread entries. It does not show all existing forms.